In this article:

Contents Search
   

 

Router BGP Configs

This article covers the configuration of routers, switches, etc. to peer with Kentik Detect in order to enable the collection of BGP data:

Notes:
- BGP peering with Kentik Detect is available only for devices on plans that include BGP; see About Plans).
- For general (not model-specific) information about router configuration, as well as information on flow export troubleshooting and on SNMP polling, see Router Configuration.
- For configuration of routers for flow export to Kentik Detect, see Router Flow Configs.
- To learn how to register routers on the Kentik system see Device Settings.
- For general information about flow, see Flow Overview.
- For information about host configuration, see Host Configuration.
- As used in this article, the term “router” refers as well to other non-host network devices such as switches.

 

 
 top

General BGP Considerations

The following general considerations apply when configuring routers for BGP peering with Kentik Detect:

  • Kentik Detect waits to hear a BGP (TCP/179) peering request from your router, after which it makes an outbound BGP connection.
  • The BGP session will be established when Kentik Detect receives the peering request, but session information will not appear in the Kentik Detect portal until flow data is received from the device.
  • Kentik Detect peers as an iBGP rr-client (same ASN as the peering router).
  • 4-byte ASN compatibility is mandatory.
  • Inbound firewall policies (ACLs) must allow inbound BGP sessions from the Kentik Detect peering IP.

Note: Kentik recommends that you filter (not propagate) your default route to Kentik Detect. If a default route is present it may override the final destination ASN assignment of all unattributed-route flow records, either with your ASN or with the ASN of your default transit provider.

 

 
 top

BGP Session Stability

Unlike normal peering or transit links, which are typically over point-to-point links, BGP sessions with Kentik typically traverse several transit providers outside the direct control of both Kentik and our customers.

  • If your BGP session with Kentik is interrupted:
    - Remember that routing will be unaffected. Our BGP sessions provide only telemetry data, they do not affect route tables.
    - Flow data received by Kentik while a BGP session is down will continue to be correlated with the last known good BGP data received from your network.
  • If needed, consider the following options to maximize the stability of your BGP sessions with Kentik:
    - Use longer timers to avoid unwanted resets when the Internet is “stormy.”
    - Contact Kentik support about bypassing the Internet by establishing a Private Network Interconnect (PNI) with Kentik.

 

 
 top

Brocade BGP Configuration

Settings to configure Brocade routers for BGP peering with Kentik (placeholders in italics):

ip prefix-list kentik-nosend deny 0.0.0.0/0
!
! Your ASN.
router bgp as_number
  ! Kentik-provided peering IP... Your ASN.
  neighbor bgp_peer_ip remote-as as_number
  ! Kentik-provided peering IP.
  neighbor bgp_peer_ip description kentik_detect
  ! Kentik-provided peering IP.
  neighbor bgp_peer_ip route-reflector-client
  ! Kentik-provided peering IP.
  neighbor bgp_peer_ip capability as4 enable
  ! Prevent short-lived reachability issues from triggering neighbor down events.
  neighbor bgp_peer_ip timers keep-alive 30 hold-time 720
  neighbor bgp_peer_ip prefix-list kentik-nosend out

Note: The BGP Peer IP assigned to your company can be found in the BGP Settings tab (see Device BGP Settings) of the Devices page (Admin » Devices) in the Kentik Detect portal.

 

 
 top

Cisco IOS BGP Configuration

Settings to configure Cisco IOS routers for BGP peering with Kentik (placeholders in italics):

!
route-map deny-all deny 10
!
! Do not send default route
route-map kentik-out deny 15
!
  match ip address 0.0.0.0/0
  continue
end
!
! Your ASN.
router bgp as_number
  ! Kentik-provided peering IP... Your ASN.
  neighbor bgp_peer_ip remote-as as_number
  ! Kentik-provided peering IP.
  neighbor bgp_peer_ip description kentik_detect
  ! Kentik-provided peering IP.
  neighbor bgp_peer_ip update-source Loopback0
  ! Prevent short-lived reachability issues from triggering neighbor down events.
  neighbor bgp_peer_ip timers 30 720
  ! Add kentik_out route-map
  neighbor bgp_peer_ip route-map kentik-out out
!
  address-family ipv4
    ! Kentik-provided peering IP.
    neighbor bgp_peer_ip activate
    ! Kentik-provided peering IP.
    neighbor bgp_peer_ip send-community
    ! Kentik-provided peering IP.
    neighbor bgp_peer_ip route-reflector-client
!

Note: The BGP Peer IP assigned to your company can be found in the BGP Settings tab (see Device BGP Settings) of the Devices page (Admin » Devices) in the Kentik Detect portal.

 

 
 top

Juniper JUNOS BGP Configuration

The following is a generic JUNOS configuration (in set notation) for BGP peering with Kentik (placeholders in italics):

# Prefix List of Routes not to send to Kentik
set policy-options prefix-list kentik-nosend 0.0.0.0/0
#
set policy-options policy-statement kentik-out term 5 from prefix-list kentik-nosend
set policy-options policy-statement kentik-out term 5 then reject
set policy-options policy-statement kentik-out then accept
#
set policy-options policy-statement deny-all then reject
#set policy-options policy-statement allow-all then accept
#
set protocols bgp group route-consumers_v4 type internal
set protocols bgp group route-consumers_v4 family inet unicast
set protocols bgp group route-consumers_v4 export kentik-out
#
# IP of route reflector router.
set protocols bgp group route-consumers_v4 cluster reflector_ip
# Kentik-provided peering IP.
set protocols bgp group route-consumers_v4 neighbor bgp_peer_ip description Kentik
# Kentik-provided peering IP... IP of any local router interface.
set protocols bgp group route-consumers_v4 neighbor bgp_peer_ip local-address local_interface_ip
# Kentik-provided peering IP.
set protocols bgp group route-consumers_v4 neighbor bgp_peer_ip mtu-discovery
# Prevent short-lived reachability issues from triggering neighbor down events.
set protocols bgp group route-consumers_v4 hold-time 720

Note: The BGP Peer IP assigned to your company can be found in the BGP Settings tab (see Device BGP Settings) of the Devices page (Admin » Devices) in the Kentik Detect portal.